Change in Exchange 2010 SP1 CAS static port configuration

For those who are using Exchange 2010 DAG and a Network Load Balancer, note that there is a small difference between RTM and SP1. If you choose to use static ports for your Client Access Servers, for the Address Book Services you would edit the Microsoft.exchange.addressbook.service.exe.config located in: “C:\Program Files\Microsoft\Exchange Server\V14\Bin”

But with SP1 (directly installed or upgraded from RTM), the location has changed to the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRpc\ParametersSystem

You have to make a new REG_DWORD with the value “TCP/IP Port” and the port number you want to use.

The setting is not automatically changed when upgrading to SP1, the ports will always be dynamically again.

If you fail to change this, Outlook users fail to connect correctly to you Exchange environment and you could end up troubleshooting for some time (I know I have…).

A lot of documentation out there for configuring static ports, was made for RTM and isn’t adjusted for SP1. So keep this in mind.

Thanks to AlexisA for some checking and testing!

Further reading

Uncovering the new RPC Client Access Service in Exchange 2010 (Part 2)

Load Balancing Exchange 2010 Client Access Servers using an Hardware Load Balancer Solution (Part 1)

Exchange 2010 SP1: Change to how static ports are assigned on a CAS server

Exchange 2010 SP1 FAQ and Known Issues

Leave a Reply

Your email address will not be published. Required fields are marked *